Программа для системы КуМир




Скачать 24.93 Kb.
НазваниеПрограмма для системы КуМир
Дата публикации06.06.2013
Размер24.93 Kb.
ТипПрограмма
litcey.ru > Информатика > Программа

«Алгоритмы с ветвлением. Реализация в системе «КуМир»».

Теоретическая часть.


Разветвляющиеся алгоритмы или алгоритмы с ветвлением, это такие алгоритмы в которых последовательность действий зависит от каких-либо условий.

Различают полное ветвление и неполное ветвление.

Неполное ветвление
если <УСЛОВИЕ (логическое выражение)>

то < серия команд>

все



Полное ветвление
если <УСЛОВИЕ (логическое выражение)>

то < серия команд 1>

иначе < серия команд 2>

все

^ Примеры алгоритмов: неполное ветвление

если на улице идет дождь

то взять зонт

все

полное ветвление

достать кошелек

пересчитать деньги

если денег больше 200 рублей

то вызвать такси

иначе ехать на автобусе

все

последовательные ветвления: вложенные ветвления:


Команда выбора
выбор

  • при условие 1: серия 1

  • при условие 2: серия 2



  • при условие n: серия n

  • иначе серия n+1

все
Решим задачу: Даны два числа А и В. Найти среди них большее.

  1. Составим математическую модель:

Пусть: А=3 и В=6

А>В, 3>6 ? нет значит, В – большее.

  1. Составим блок-схему:



  1. Программа для системы КуМир

алг БИД

нач цел а,в

ввод а, в

если а> в

то с:=а

иначе с:=в

все

вывод с

кон
^

Практическая часть.


  1. Вычислить значение функции

  2. Найти наибольшее их трех данных чисел а, в и с.

Результат работы:

Решение задачи 1)

алг БИТ1

нач цел а,в,с,d

ввод а, в, c

если а > в

то d:=а

иначе d:=в

все

если c> d

то d:=c

все

вывод d

кон

2)

алг функция

нач цел х, у

ввод х

при x > 0: y:= x - 2

при x = 0: y:= 5

при x < 0: y:= x** 2

все

вывод у

кон


Похожие:

Программа для системы КуМир iconПример решения домашнего задания (КуМир MacOS)
Надо: Написать программу на алгоритмическом языке КуМир, подсчета количества четных элементов с нечетными номерами целочисленного...
Программа для системы КуМир iconПрограмма-минимум кандидатского экзамена по специальности 05. 13. 01
Выделение системы из среды, определение системы. Системы и закономерности их функционирования и развития. Управляемость, достижимость,...
Программа для системы КуМир iconПрограмма инист банк-Клиент Техническое описание и система безопасности
В этом разделе описываются основные понятия, используемые в системе Банк Клиент, компоненты системы и пользователи системы. Данная...
Программа для системы КуМир iconРабочая программа дисциплины «Операционные системы и среды» для специальности...
Федеральное государственное образовательное учреждение среднего профессионального образования
Программа для системы КуМир iconРабочая программа по предметам образовательной системы «Начальная...
Рабочая программа составлена на основе Федерального государственного образовательного стандарта начального общего образования и программы...
Программа для системы КуМир iconРабочая программа по предметам образовательной системы «Начальная...
Рабочая программа составлена на основе Федерального государственного образовательного стандарта начального общего образования и программы...
Программа для системы КуМир iconРабочая программа по предметам образовательной системы «Начальная...
Рабочая программа составлена на основе Федерального государственного образовательного стандарта начального общего образования и программы...
Программа для системы КуМир iconРабочая программа дисциплины Автоматизированные информационные системы...
Федеральное государственное образовательное учреждение среднего профессионального образования
Программа для системы КуМир iconЕкатерина Вильмонт Два зайца, три сосны Кумир поверженный все Бог
У мамы. У нее рукопись готовая на столе лежала, и первая глава называется «Две задрыги из Мухлыни»
Программа для системы КуМир iconПрограмма развития воспитательной системы «Овация за успех»
Программа развития воспитательной системы Муниципального бюджетного общеобразовательного учреждения
Вы можете разместить ссылку на наш сайт:
Школьные материалы


При копировании материала укажите ссылку © 2013
контакты
litcey.ru
Главная страница